Results 1 to 2 of 2

Thread: "Cannot read sector 0" Error on USB, please help

  1. #1
    Just burned his ISO
    Join Date
    Aug 2008

    Default "Cannot read sector 0" Error on USB, please help

    I have searched through 21 pages of forums and I cannot find anyone mentioning this. I have used the tutorial to create a 4 partitioned 8gb usb drive as follows:

    1: fat32
    2: swap
    3: ext2
    4: fat32

    I can see these partitions and access them in BT3. I can also access the fat32 partitions in windows. The problem is when I try to run bootinst.bat (from within the usb drive), it says the following:

    Setting up boot record for f: wait please...
    Cannot read sector 0
    Disk f: should be bootable now. Installation finished...

    Then, when I try to boot it says "Cannot find operating system" and boots into windows as well. The strange thing is I had this same usb drive working when I first tried out BT3 (on 1 partition only) but I wanted to make pervasive changes, so I reformatted it into the four partitions recommended.

    Does this mean something is wrong with my MBR? I have tried reformatting the drive and going through the steps again, but to no avail...

    A follow up question: How do you reset the MBR back to the factory default? Does formatting a drive over again reset the MBR?

    Thanks guys for all your help.

  2. #2
    Junior Member
    Join Date
    Aug 2008


    you have bad sector on usb dongle

    sounds like your partitioning and formatting need re-doing. try using acronis disk director for windows. or if using cd to boot bt3, use qt parted.

    if it fails a few times, need new dongle.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts